Now Supporting 2.x!

Allison Zadrozny · April 15, 2016
1 minute read

We’re excited to announce that we now support ES 2.2.2 in addition to 1.7.5 and 1.5. We’ve spent quite a bit of time improving our infrastructure to ensure 2.x will be a stable, blazing-fast build. Two weeks ago we shipped a button that allows anyone to upgrade their cluster to 2.2.2:

Because of backwards incompatibility with 2.x, clusters on 1.7 won’t be able to upgrade if they have data on them. If you have active shards, you will see a warning message and your button will be disabled:

So, make sure to clear your cluster! You can do this by running curl -XDELETE "BONSAI_URL"

Elasticsearch v5 should be ready by the end of the year, and we don't expect any updates to 1.x after this release. In early January 2017 we'll phase out support for 1.x on non-dedicated plans, so we recommend all of our users to start their process of moving off of 1.x and into 2.x.